EmbDev.net

Forum: µC & Digital Electronics ESP32+WLED / no LED control


von Stev (Guest)


Attached files:

Rate this post
useful
not useful
Hello, everyone,

even if there is already a similar thread here 
(Beitrag "ESP32 welche Einstellungen in WLED?"), I actually have pretty 
much the same problem and can't get it solved.

I have an AZ-Delivery ESP32 Dev Kit C V2 ESP32-WROOM-32, plus WS2815 LED 
strips 5m from BTF-Lighting, as well as an ext. power supply on 12VDC 
(20A).

Flashing the ESP32 with the current WLED version (including the current 
WLED Sound reactive version) worked great. The web interface and app 
access work.

However, my LEDs do more or less what they want. As soon as the Data PIN 
is connected, the LEDs flash colorfully. They do everything, just not 
what I specify in the app or via the web interface. Something seems to 
work ..... if I set 20 LEDs in the settings, only about 20 LEDs come on 
(flashing). If I set more, more LEDs will flash. But none of them do 
what they should. Do you have a tip for me as to what I'm doing wrong? 
Is the board possibly not supported?

As already described, the 12VDC is provided by an external power supply 
unit.
I tested different GPIOs ... always the same problem.

Example: Connection of DataIN to pin G2 with the following settings in 
the WLED:

Total LED count: 20
2D matrix: 1x20
LED voltage (Max.current for a single LED): WS2815 (12mA)
LED outputs: WS281x
Color Order: RGB
Pin: 2
Start: 0
Count: 20

Do any of you still have an idea?

Thanks in advance.

VG Stev

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig