EmbDev.net

Forum: µC & Digital Electronics STM32H7 real-time data tracing via SWD not working


von Solocan Z. (solocan)



Rate this post
useful
not useful
Hello community,

I'm desperately trying to get my new Nucleo H743ZI real time data 
tracing work. No success since 3 days.

Flashing and asynchron debug (Start/Pause/Watch variables on pausing) 
work. BUT the real-time data tracing using SWD with onboard STLINK 
debugger doesn't work -whether software tracing (printf) nor hardware 
tracing (watch variables with SWV). I simply get no data transmitted 
from MCU when program is running...Please see screenshots with configs 
and explanations.

Toolchain: CubeMX->Atollic 
TrueStudio->USB->STLink->MCU->SWD->STLink->USB->Atollic TrueStudio 
(Windows 10).

What I tried:

-Many official tutorials  Data sheets  Application notes including:
-http://blog.atollic.com/cortex-m-debugging-real-time-variable-watch-using-swv/swo
-http://blog.atollic.com/cortex-m-debugging-introduction-to-serial-wire-viewer-swv-event-and-data-tracing
-http://blog.atollic.com/cortex-m-debugging-printf-redirection-to-a-debugger-console-using-swv/itm-part-1
-printf() function redirected as described in many manuals
-Reading SWIO Pin PB3 with oscilloscope (No edges detected)
-Reading STLINK Jumpers with oscilloscope (Edges detected)
-Other IDEs SW4STM32 (No success)
-Serial wire viewer of STLINK (nothing shown)
-Tried debugger and builder / optimization settings. (Still no success)

See screenshots for detailed description and the configurations.

Please help me finding the cause of this issue. I appreciate every hint 
and suggestion.

Thank you very much

von A. B. (Guest)


Rate this post
useful
not useful
Solocan Z. wrote:
> -Reading SWIO Pin PB3 with oscilloscope (No edges detected)

You mean SWO (PB3), not SWIO, I guess? Well, that's not exactly 
real-time trace data. But anyway, look there:

https://community.st.com/s/question/0D50X00009XkhURSAZ/stm32h7-swo-printf-not-working

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.