EmbDev.net

Forum: µC & Digital Electronics Wordclock stopped working


von Sasa D. (fibra)


Attached files:

Rate this post
0 useful
not useful
Hi everybody! My name is Sasha and this is my first post here.

As I understand this forum is English version of Mikrocontroller.net so 
it is very strange search found nothing about Wordclock project.

I have built myself this amazing clock based on PCB from Shapelabs: 
https://shapelabs.de/mechanisches/wordclock.htm
It was working fine few days than it freezes 2 times and finally stopped 
working. It is completely blank now or it have just 4 (minutes LEDs) on. 
LED test shows LEDs are fine. DFPlayer plays the sound manually. IR 
remote does not work.

Hooking it up on serial monitor it shows all parts are online but from 
web interface RTC, EEPROM and DFPlayer are offline!
LDR shows no values, DS1820 shows no temperature, time does not update, 
there are no Animations, it forgets change in settings I make after 
powering off. I have tried to update firmware and reset EEPROM, but no 
change.
1
Welcome to WordClock Logger!
2
----------------------------
3
irmp_init...
4
power_init...
5
power_init() called
6
power_on...
7
switching power on
8
delay_init...
9
board_led_init...
10
button_init...
11
timer2_init...
12
wpsbutton_init...
13
Version: 2.9.5
14
Hardware: STM32F103
15
Display: WC12h
16
LEDs: WS2812 GRB
17
rtc is online
18
eeprom is online
19
ws2812: external pullup detected
20
eeprom is online
21
current eeprom version: 0x00000000
22
updating EEPROM to version 0x00020900... done
23
DFPLAYER LOGGER
24
ESP8266 LOGGER
25
read rtc: Su 2000-01-01 00:00:13
26
read rtc: Su 2000-01-01 00:00:13
27
DFPlayer: SD card online
28
DFPlayer: query software version
29
DFPlayer: Version 0008
30
DFPlayer: set source device: 2
31
DFPlayer: set eq 0
32
DFPlayer: set volume 0
33
DFPlayer is up
34
dfplayer is online
35
esp8266 now up
36
(- setup UDP)
37
(- local port: 2421)
38
(- setup server UDP)
39
(- local port: 2424)
40
(FIRMWARE 2.9.5)
41
(- tables found; wc12h-tables-en2.txt)
42
(- check tables successful)
43
--> tabinfo<0d><0a>
44
(- connected to AP)
45
(AP crvenkapa)
46
(MODE client)
47
(IPADDRESS 192.168.1.104)
48
info: ip address = 192.168.1.104

von stefanus (Guest)


Rate this post
0 useful
not useful
Measure the Voltage on SDA and SCL lines, which should be 3,3V in idle 
state.

If not, then remove one I²C chip after the other and powercycle the 
device until the voltage is Ok.

If you removed everything but the voltage is still not 3,3V then a 
pull-up resistor is possibly not working or you have a short-circuit to 
GND.

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.