Forum: ARM programming with GCC/GNU tools arm cross compiler

von david d. (Company: upmc) (davee)

Rate this post
0 useful
not useful

I am trying to install the cross-compiler for the processor arm on 
ubuntu 10.04
I installed binutils-2.20, gcc-4.4.2 and gdb-6.7.1.

to install gcc, I used these commands:
sudo .. / ../../src/gcc-4.4.2/configure --prefix=/usr/local/SocLib/ 
toolchain/arm --target=arm-unknown-elf --program-prefix=arm-unknown-elf 
-- disable-nls --disable-werror --enable-languages​​=c --disable-libssp 
--disable-threads --without-headers.

2) sudo make

3) sudo make install.

After these steps, a file will be generated automatically 
"arm-unknown-elf-gcc", but the problem is that I find 

how to solve this problem.

thank you in advance

von profWho (Guest)

Rate this post
0 useful
not useful
Unfortunatly have the same error,
still looking for the result?
or have you found something?

von Uwe Bonnes (Guest)

Rate this post
0 useful
not useful
Try the packages found at

They work for me out of the box for Opensuse 12.3 on X86-64.


von Rene H. (Guest)

Rate this post
0 useful
not useful
Hi David,

did you already tried a symbolic link? I guess this should solve your 



Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]

Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.