EmbDev.net

Forum: µC & Digital Electronics STM32 & ADC AD7699: fading SPI MISO level


von Jan Bolting (Guest)


Attached files:

Rate this post
useful
not useful
Hey guys,

I'm facing a problem working with an STM32F103RET6 and an ADC AD7699
(datasheet: 
http://www.analog.com/static/imported-files/data_sheets/AD7699.pdf).
I thought maybe some of you might have similar experiences and could 
give me a hint. As you can see in the pictures, the signal level of the 
AD7699's SDO (SerialDataOut) pin doesn't drop straight to LOW during the 
last falling edge -though it does looking at the edges before, so I 
suppose it's not an electric issue - but slowly fades to LOW.
Any idea?


best regards
Jan

von soundso (Guest)


Rate this post
useful
not useful
looks like the sdo pin is going tristate (high impedance) at the end of 
the transmission. if so it is a electrical problem.

use a pulldown or pullup resistor on the line for a defined voltage 
level ...

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.