Forum: ARM programming with GCC/GNU tools Error when reading FIO1PIN on LPC23xx

von Alfredo C. (tequilaguru)

Rate this post
0 useful
not useful

I build my own toolchain, but I ran into a problem, both when using the 
toolchain on cygwin and mingw (tried building both, same error).

Basically the toolchain works fine, but when I debug using 
Openocd+arm-elf-gdb. I can't read FIO1PIN or FIO1XXX for that matter 
without having the value of those registers corrupted. I can read and 
write any other register without a problem, and the code interacts with 
those registers just fine.

The problem arises when reading the registers using the the debugger. No 
matter if I use the GUI like "add to watch" in insight or eclipse, this 
also happens if I try to read the memory area using eclipse or insight 
memory view. Or in the gdb console using "monitor mdw FIO1PIN".

I am using gcc 4.4.2, gdb 7, newlib 1.17 and insight 7. This also 
happens if I switch my toolchain to YAGARTO. Has anyone run into this 
issue before?. Can anyone reproduce this?.


Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]

Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.