EmbDev.net

Forum: µC & Digital Electronics Problem with Atmega 644 Programming


Author: Problem with Pollin AVR EvaluationBoard 2.01 (Guest)
Posted on:
Attached files:

Rate this post
0 useful
not useful
Hi!, i´m new on this forum, my name´s Alvaro and i´m spanish.

 I need some help with Ponyprog programer and a new ATMEGA644 20PU, 
trying to program with a ATMEL evaluationboard 2.01 ( from Pollin.de), 
via ISP, com 4

 I´m going to describe exactly my problem

 I´m developing a aplication to control a Satelite receiver, i was 
working with an ATMEGA32 and all were fine, i can program it with 
Ponyprog and my programmer, but now i need more memory , so i toke a 
Mega644, when i received it, i recompiled my code to this micro and try 
to program it (It has the same pinout that ATMEGA32), but ponnyprog says 
to me "Device missing or unknown device (-24)", i tried all, try to 
change the fuses ignoring this message, try to program ignoring this 
too..., finally i take a new ATMEGA644 thinking that maybe the micro 
what it´s damaged, but with the new one i have the same error...
 Actually i can program with the same programmer and software my MEGA32 
without any problem, but no the AT644....

 I´m doing something wrong??, i don´t have any idea what´s happening..., 
so please help me!!

 If it helps, this is my programmer:
 www.pollin.de/shop/downloads/D810038B.PDF

 Thanks!!!

 Alvaro

Author: micha (Guest)
Posted on:

Rate this post
0 useful
not useful
Did you change the Device settings to the right AVR in PonyProg?

Author: Problem with Pollin AVR EvaluationBoard 2.01 (Guest)
Posted on:

Rate this post
0 useful
not useful
Hello, thanks for your reply

Yes , i changed the settings for this micro, recompile my program to 
this microcontroller, try to program with AVRdude..., try to program 
ignoring the error message..., but nothing works....

Author: atmega8 (Guest)
Posted on:

Rate this post
0 useful
not useful
I work with Atmega644 and PonyProg too, there are no Problems in my 
case.
But I don't use the Board from Pollin, I have made my own STK200 
Compatible Programmer.

Author: yaser (Guest)
Posted on:
Attached files:

Rate this post
0 useful
not useful
Hi!, i´m new on this forum, my name´s yaser and i´m Iranian

I need some help with STK 200 programmer and  ATMEGA32
  I,m trying to make a control board with atmega32, but unfortunately in 
programming with bascom software it says:
 can not identify ID FFFFF, AND Does not match m32 with 902...
please help me.

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.