EmbDev.net

Forum: ARM programming with GCC/GNU tools Yagarto tools - Make 64 bit windows - Error


Author: Juha (Guest)
Posted on:

Rate this post
0 useful
not useful
Hi,

I have litle problem with Yagarto tools make command in 64 bit Windows.
Yagarto tools works ok with 32 bit Windows 7 (laptop)

Error:
C:\ARM\LEDglow_LPC2138>make
make: Interrupt/Exception caught (code = 0xc00000fd, addr = 0x425073)

Have anyone seen this error?

Author: Clifford Slocombe (clifford)
Posted on:

Rate this post
0 useful
not useful
Since make is independent of the code generation tools, you might simply 
replace it with a 64 bit version of make. There is one available here: 
http://www.equation.com/servlet/equation.cmd?fa=make

An alternative but somewhat heavyweight solution may be to run a 32bit 
version of Windows in a virtual machine on your 64bit platform.

Both VMware Server and Virtual PC are free and will allow you to do 
this. One advantage of a VM is that it provides a consistent and 
standardised virtual platform regardless of the physical hardware and 
drivers installed. Because you can have a virtual network between the VM 
and the host (and the rest of your physical network) accessing files in 
either environment can be seamless.

http://www.microsoft.com/downloads/details.aspx?Fa...

http://www.vmware.com/products/server/

If you do not have a spare Windows license to install on the VM, you can 
use one of the IE compatibility test VHDs for Virtual PC, which are in 
fact time-limited full OS installations. 
http://www.microsoft.com/downloads/details.aspx?di...


Clifford

Author: XploD (Guest)
Posted on:

Rate this post
0 useful
not useful
I got the same error message, but the solution was plain simple:
Don't install the yagarto into a directory containing spaces (like 
"Program Files(x86)")

On my Win7 64bit machine, installing the toolkit in c:\yagarto\ fixed 
the issues...

Author: Clifford Slocombe (clifford)
Posted on:

Rate this post
0 useful
not useful
XploD wrote:
> I got the same error message, but the solution was plain simple:
> Don't install the yagarto into a directory containing spaces (like
> "Program Files(x86)")

Oh yes; never do that with any GNU tools, especially make.  You may be a 
bit late with the suggestion however; thread necromancy is seldom 
useful.

Author: Helge (Guest)
Posted on:

Rate this post
0 useful
not useful
Thank you very much!

I have searched longer days.
Now I read this post and my problem is solved!

Thanks.

Helge

Author: snOwen (Guest)
Posted on:

Rate this post
0 useful
not useful
Alternatively, edit the PATH environment variable to use the *short 
names* for the directories where Yagarto is intalled, e.g.:
PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\yagarto-tools-20100703\bin;C:\Program Files (x86)\yagarto\bin

becomes:
PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\PROGRA~2\YAGART~1\bin;C:\PROGRA~2\yagarto\bin

(Use 'dir /x' in the command shell to check the actual short name of 
each directory, and see 
http://geekswithblogs.net/renso/archive/2009/10/21... 
for info on editing the PATH)

-Owen

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.