Forum: µC & Digital Electronics Siemens S65 on AVR ATmega128, strange Colours!!?!?!

Author: Philip Mulrane (pmul)
Posted on:
Attached files:

Rate this post
0 useful
not useful
Hi all,
I've built a board according to Christian Kranz's spec.
I've compiled the gcld lib on his homepage as per the install.txt 
(mcu,clock, pins all defined for my setup).
I've used a Mega128 16Mhz, I've used the same IO pins has he does.
For the voltage divider leading from the PORTB pins to the display I've 
used 470 Ohm inline with the port pins and 560 Ohm to ground. The 
display in question was bought new from ebay, and looks exactly like 
(i.e. including numbers, etc.) the LS020xxx on Cristian's site.
The circuit works, however the display is a bit 'funny' (see image 
I seem to have an incomplete colour spectrum, only greens and purples 
being involved. And the fonts look 'chewed'. I've tried recompiling the 
lib with 64K colours and 256 colours, no change.
Anyone got any bright ideas?

Author: Дмитрий Л. (gottdrak99)
Posted on:

Rate this post
0 useful
not useful
I've got some problems by using 560 Ohm (after 20 seconds i've got some 
crashes). Put one 100 Ohm resistor as serie circuit after all port pins


Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]

Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.