Forum: FPGA, VHDL & Verilog Problem about DCM phase alignment

Author: ZHEN SU (Company: OSU) (xmuszq)
Posted on:
Attached files:
  • preview image for 1.png
    35 KB, 172 downloads
  • preview image for 1.jpg
    50.7 KB, 162 downloads
  • preview image for 2.jpg
    175 KB, 210 downloads

Rate this post
0 useful
not useful
according to datasheet, the CLKIN( labled '3') and CLKFB ( labled '6') 
are aligned, namely the phase of 3 and 6 should be the same, or we say 5 
and 3 should be the same as 5 and 6 are on the same wire.
then in my post-route simulation in ISIM, the clock is 375MHz, and it's 
in Xilinx Vertex 4 FPGA.  I use above mode, the phase  of 3 and 6 are 
the same, but 5 and 3 are quite different.  Also, the phase between 2 
and 3 are different. What's wrong with it? Is it a route delay?. in fact 
they are on the same line. if it's a route delay, is that possible that 

Author: Hassan Al Ashraui (Guest)
Posted on:

Rate this post
0 useful
not useful
You do not expect a Xilinx ISIM Simulation showing you the right 
relations in phases?  Did you proove that in reality?


Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [vhdl]VHDL code[/vhdl]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]

Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.