EmbDev.net

Forum: ARM programming with GCC/GNU tools YGA toolchain install overwrites PATH variable


Author: Joe at Moto (Guest)
Posted on:

Rate this post
0 useful
not useful
I have just installed the Yagarto GNU ARM Toolchain onto my WindowsXP 
Pro SP.2 machine from the http://www.yagarto.de/ website.
As promised on the yargarto site ("The installer will change the path 
for you automatically"), the installer changed my path.  However instead 
of merely appending the yargarto tool pathname to my PATH variable, it 
REPLACED it with this: ";C:\Program Files\yagarto\bin"
I was able to restore my old (and admittedly long at 1650 characters) 
PATH variable using System Restore, but I had some choice words for this 
installation in the meantime.  I then appended the yagarto pathname to 
my PATH variable using the old method.  In short, no lasting damage.
I don't know what happened, but I notice that the release (11.03.2009) 
is only 9 days old.  Perhaps no one else has noticed this problem in the 
last week.  Still someone should check this out and fix it if there is 
indeed something wrong with the installer.

Author: Michael Fischer (mifi)
Posted on:

Rate this post
0 useful
not useful
Hello Joe,

>However instead of merely appending the yargarto tool
>pathname to my PATH variable, it
>REPLACED it with this: ";C:\Program Files\yagarto\bin"
Sorry for that.

I have heard this before one time, but could not
find the problem here, and even could not reproduce
the problem.

>Still someone should check this out and fix it if there is
>indeed something wrong with the installer.
It is the same as all the other installer/scripts before,
I only change the content.

Best regards,

Michael

Author: Gary Embler (Company: Google Inc.) (gembler)
Posted on:

Rate this post
0 useful
not useful
I stumbled into this problem also. It is a bug in the NSIS installer. 
See

http://forums.winamp.com/showthread.php?s=af27e538...

The Yagarto installation instructions should add a warning about this 
bug. Otherwise Yargarto is an excellent tool and kudos to Michael for 
providing it.

-Gary

Author: Michael Fischer (mifi)
Posted on:

Rate this post
0 useful
not useful
Hello Gary,

many thanks for the hint, in the last days GCC 4.4.2 was released.
If I create a new version of YAGARTO I will take a look at the
installer problem and check the "Large string" build of NSIS.

Best regards,

Michael

Author: Steven Snyder (series8217)
Posted on:

Rate this post
0 useful
not useful
The latest YAGARTO installer seems to work fine.

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.