EmbDev.net

Forum: ARM programming with GCC/GNU tools yagarto versions confuses me


Author: John S. (john77)
Posted on:

Rate this post
0 useful
not useful
Hi,

there are a lot different versions of the yagarto and yagarto ide. One
year ago I downloaded one, now I want to upgrade. May I deinstall all
and install the new one? And than what is about my projects and
workspace for eclipse? Or is it possible only to update the gdb or
insight or other components? Or should I stay with the older version?
I'm confused a little bit.

With the openocd there is no problem, i use the newest version.

Can someone give me an advice, which configuration works stable with
SAM7XC and Olimex ARM-USB-OCD and openocd version 275?

Thanks a lot
John

Author: Tilo L. (katagia)
Posted on:

Rate this post
0 useful
not useful
John S. wrote:
> ... now I want to upgrade.

Why do you want to upgrade?
Is there any need to upgrade because you
have problems with an older version?

Author: John S. (john77)
Posted on:

Rate this post
0 useful
not useful
Hi

now I want to give some reasons for me
First at my one PC I use version 3.2 of Eclipse. During debugging in
flash between each step) I get the information, that the Embedded GDB
(atm-elf-gdb and main.outI is suspended. Also if I step one step, it
steps over some lines in C code.
Second reason is, that I want to use a other JTAG-Adapter(with hardware
I developed myself) and want to test out, if it works with the current
version.
And last but not least I want to be up-to-date.
Thanks for reading and answering Tilo.

Cheers
John


Tilo Lutz wrote:
> John S. wrote:
>> ... now I want to upgrade.
>
> Why do you want to upgrade?
> Is there any need to upgrade because you
> have problems with an older version?

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.