EmbDev.net

Forum: ARM programming with GCC/GNU tools arm-elf-gcc not found error message


Author: Tarun (Guest)
Posted on:

Rate this post
0 useful
not useful
I am using, lpc2xxx controller arm7 core.
All of the sudden when i tried to compile my program using make in pn
editor i sdtarted facing the problem with error message exactly as
writen below...
kindly provide support on this. I have been doing this thing since last
many days. but today suddenly this problem started. I have tried
reinstalling WinARM


arm-elf-gcc: not found
make: *** [gccversion] Error 127

Author: Super Mario (techbuddy)
Posted on:

Rate this post
0 useful
not useful
check to see if the path is proper in the PATH according to the
installation guidelines.
also check if some other applications such as ( GNUARM or Cygwin ) are
in the PATH. If yes, please remove them.
If you are using XP, please delete make*.* files in c:\windows\prefetch\
.. restart the computer.
Things might help.  (atleast it did for me )

Tutu

Author: Tarun (Guest)
Posted on:

Rate this post
0 useful
not useful
Tutu Ag wrote:
> check to see if the path is proper in the PATH according to the
> installation guidelines.
> also check if some other applications such as ( GNUARM or Cygwin ) are
> in the PATH. If yes, please remove them.
> If you are using XP, please delete make*.* files in c:\windows\prefetch\
> .. restart the computer.
> Things might help.  (atleast it did for me )
>
> Tutu



dear, cygwin not installed...
tried deleting make*.* files...
didnt work..
tell me about these  path settings.. and how can it happen when i have
been compiling it from last many days..
any ways assist for PATH settings..
Tarun

Author: Super Mario (techbuddy)
Posted on:

Rate this post
0 useful
not useful
did u use another IDE while using WinARM ? The same problem occured to
me only when I used another IDE at the same time WinARM was installed.
When you have been compiling for many days, then it is unlikely that
your path settings are incorrect.
I dont know. Sorry

Tutu

Author: Jim Kaz (ancaritha)
Posted on:

Rate this post
0 useful
not useful
It is unlikely to be your path settings since it was working previously,
but it can't hurt to double check them.  If you aren't sure how to do
this:

Right click on 'My Computer' and click on properties.  Click on the
'Advanced' tab, and then the Environment Variables button.  Under the
'System Variables' section there should be a variable called PATH.  It
should have  C:\WinARM\bin;C:\WinARM\utils\bin; in it.

Reply

Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]




Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.