Forum: FPGA, VHDL & Verilog New Spartan 3 Board: Wrong ID Code retuned ?

Author: Rene G. (reneg)
Posted on:

Rate this post
0 useful
not useful
Hi Group

Sorry im writting in English, but my written German is not good enought 
for explaning my problem, but please answer in German reading no
problem :-)

I have developed my own Xilinx SPARTAN3-400 board but have a problem 
when trying to connected via JTAG to the FPGA, i am using the USB Cable 
from Xilinx but with out luck.

There is only one FPGA in the chain, i have rechecked power sequencing, 
and recehecked the connection to the FPGA JTAG/POWER/Ect.

The ID code i can read from the spartan via Chain debug in Impact:

I have tested when a eval board from memec with the same FPGA which 

I really dont have any ideas more whould could be the problem, are there
somebody how can give me a hint to would me could be te problem ?

Thanks a lot in advance

Best regards

Author: Lothar Miller (lkmiller) (Moderator)
Posted on:

Rate this post
0 useful
not useful
Programmer TDI --> FPGA TDI
FPGA TDO --> Programmer TDO
You've double checked this?

Do you have pullups on the TDI- and TDO-Pins?


Entering an e-mail address is optional. If you want to receive reply notifications by e-mail, please log in.

Rules — please read before posting

  • Post long source code as attachment, not in the text
  • Posting advertisements is forbidden.

Formatting options

  • [c]C code[/c]
  • [avrasm]AVR assembler code[/avrasm]
  • [vhdl]VHDL code[/vhdl]
  • [code]code in other languages, ASCII drawings[/code]
  • [math]formula (LaTeX syntax)[/math]

Bild automatisch verkleinern, falls nötig
Note: the original post is older than 6 months. Please don't ask any new questions in this thread, but start a new one.